We’ve identified the issue. An abnormal spike in signaling activity on our US PGW for G2 profiles (89357*) is causing intermittent failures when devices attempt to establish new sessions. During these spikes, the PGW is running out of available resources, which leads to session setup attempts failing.
We’re working closely with our upstream partners to expand capacity on the PGW and put additional stabilizing measures in place.
We’ll share further updates as this work progresses.
Posted Nov 18, 2025 - 18:13 UTC
Update
We are continuing to investigate this issue.
Posted Nov 18, 2025 - 15:13 UTC
Investigating
We are currently investigating an issue where a small number of G2 profiles are reported to have issues when trying to open new sessions.
Posted Nov 14, 2025 - 16:28 UTC
This incident affects: Cellular Networking (Global Cellular Data Network, SMS over cellular - Device Terminated, SMS over cellular - Device Originated).