UK degraded connectivity (O2 2G/3G network sunset)

Incident Report for Hologram

Update

We are continuing to investigate this issue.
Posted Nov 07, 2025 - 19:16 UTC

Update

We are continuing to investigate this issue.
Posted Nov 07, 2025 - 19:14 UTC

Investigating

Starting October 1st, 2025, O2 UK began decommissioning its 2G and 3G networks across the UK, with full shutdown expected by the end of the year.

As a result, devices using these legacy networks are transitioning to other available carriers.

Some Cat-M/LTE-M devices with 2G fallback that were previously using O2's 2G network are having trouble transitioning to other available carriers.

We're reviewing impacted devices and finding connectivity alternatives for these.

Please reach out to support@hologram.io if you're experiencing connectivity issues in the UK.
Posted Oct 23, 2025 - 19:31 UTC
This incident affects: Cellular Networking (Global Cellular Data Network).